Critical Bug Identified: Organization administrators unable to access the People section in showd.me app.
Incident Report for showdme
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 10:48 EST
Investigating
We are currently investigating this issue.
Posted Feb 27, 2024 - 10:37 EST
This incident affected: Desktop Site (People Directory).