Showd.me is back online, with the scheduled upgrade successfully completed.
Thank you for your patience!
Posted Jun 01, 2025 - 16:45 EDT
In progress
Our platform is temporarily offline for scheduled upgrades.
Scheduled upgrade is currently in progress. Our new estimated completion time is Sunday, June 1, 2025 at 05:00 pm EDT.
Posted May 30, 2025 - 21:10 EDT
Scheduled
We're Improving Your Experience!
Our platform is temporarily offline for scheduled upgrades.
During this time, we're deploying our major Facility/Agencies update, designed to streamline user and organizational data management for both Skilled Nursing and Home Health.
Our estimated completion time is Sunday, June 1, 2025 at 12:00 pm EDT.